Bug #69070

When extracting a t3x file after upload, the dependencies are not written to ext_emconf.php

Added by Helmut Hummel over 4 years ago. Updated over 1 year ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
-
Target version:
-
Start date:
2015-08-14
Due date:
% Done:

100%

TYPO3 Version:
7
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

When extracting the t3x archive, the EM_CONF data is taken to create a new ext_emconf.php file.
An already extracted ext_emconf.php file is overwritten in this process.

Since those t3x files are created by TER server and this TER server does not include the extension constraints in this array,
all constraints are lost in this process.

To fix this, it is needed to use a present ext_emconf.php file and merge the meta properties with its properties to construct the final ext_emconf.php


Related issues

Related to TYPO3 Core - Bug #73896: Old constraints in ext_emconf.php after extension update with active opcode cache Closed 2016-03-02

Associated revisions

Revision 9ee2a54f (diff)
Added by Helmut Hummel over 4 years ago

[BUGFIX] Fix dependencies for t3x upload

When extracting the t3x archive, the EM_CONF data is taken to
create a new ext_emconf.php file.
An already extracted ext_emconf.php file is overwritten in this process.

Since those t3x files are created by TER server and this TER server
does not include the extension constraints in this array,
all constraints are lost in this process.

To fix this, it is needed to use a present ext_emconf.php file
and merge the meta properties with its properties to construct
the final ext_emconf.php.

Resolves: #69070
Releases: master, 6.2
Change-Id: I3997bee05f256a3ff23f0eee516ecf0a323017c3
Reviewed-on: http://review.typo3.org/42619
Reviewed-by: Nicole Cordes <>
Tested-by: Nicole Cordes <>
Reviewed-by: Markus Klein <>
Tested-by: Markus Klein <>

Revision 891ddd2c (diff)
Added by Helmut Hummel over 4 years ago

[BUGFIX] Fix dependencies for t3x upload

When extracting the t3x archive, the EM_CONF data is taken to
create a new ext_emconf.php file.
An already extracted ext_emconf.php file is overwritten in this process.

Since those t3x files are created by TER server and this TER server
does not include the extension constraints in this array,
all constraints are lost in this process.

To fix this, it is needed to use a present ext_emconf.php file
and merge the meta properties with its properties to construct
the final ext_emconf.php.

Resolves: #69070
Releases: master, 6.2
Change-Id: I3997bee05f256a3ff23f0eee516ecf0a323017c3
Reviewed-on: http://review.typo3.org/42642
Reviewed-by: Nicole Cordes <>
Tested-by: Nicole Cordes <>

History

#1 Updated by Gerrit Code Review over 4 years ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/42619

#2 Updated by Gerrit Code Review over 4 years ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/42619

#3 Updated by Gerrit Code Review over 4 years ago

Patch set 3 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/42619

#4 Updated by Gerrit Code Review over 4 years ago

Patch set 4 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/42619

#5 Updated by Gerrit Code Review over 4 years ago

Patch set 5 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/42619

#6 Updated by Nicole Cordes over 4 years ago

You can try the patch with the following extensions:

- static_info_tables => current version isn't compatible to git master
-> should open the "I know what I'm doing" window, but can be installed without problems

- tt_products => has defined multiple dependencies (see typo3.org)
-> should not be possible to be installed

#7 Updated by Gerrit Code Review over 4 years ago

Patch set 1 for branch TYPO3_6-2 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/42642

#8 Updated by Gerrit Code Review over 4 years ago

Patch set 2 for branch TYPO3_6-2 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/42642

#9 Updated by Helmut Hummel over 4 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#10 Updated by Benni Mack over 1 year ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF