Bug #69370

Implicitly allow access to Web module if access to submodule is granted

Added by Oliver Hader over 5 years ago. Updated almost 4 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Backend User Interface
Target version:
-
Start date:
2015-08-27
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
7
PHP Version:
5.5
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

Uncaught TypeError: Cannot read property 'split' of undefined in modulemenu.js:135

Did not analyze further yet...


Files

Bildschirmfoto 2015-08-27 um 18.09.39.png (527 KB) Bildschirmfoto 2015-08-27 um 18.09.39.png Oliver Hader, 2015-08-27 18:11
typo362.png (38.3 KB) typo362.png Riccardo De Contardi, 2017-02-18 23:08
typo37andabove.png (45.6 KB) typo37andabove.png Riccardo De Contardi, 2017-02-18 23:08
#2

Updated by Oliver Hader over 5 years ago

  • Subject changed from Empty backend for non privileged users to Implicitly allow access to Web module if access to submodule is granted

The user did not have permission to module "Web", but to "Web>Page". Maybe this can be resolved implicitly...

#3

Updated by Riccardo De Contardi about 4 years ago

As far as I can see:
1) On TYPO3 6.2, if you try to assign a submodule (like web>page) to a fe usergroup, but not the module (web) an error is given (see attached typo362.png)
2) On TYPO3 7.6.15 and the latest master, it is not possible anymore to assign a submodule, but not the parent module (see attached typo37andabove.png)

On TYPO3 7.6.15 I performed the following test:

1) create a usergroup with only Web>Page assigned
2) assign an user to the group, don't assign modules to the user.

And

3) create a usergroup with no modules assigned
4) assign an user with only Web>Page assigned

On both cases, I did not find javascript errors at the login.

Do you consider this sufficient to consider this issue closed? Thank you.

#4

Updated by Oliver Hader almost 4 years ago

  • Status changed from Needs Feedback to Closed

Seems to be fine for TYPO3 CMS 7 then...

Also available in: Atom PDF