Bug #69592

Cannot add scheduled tasks

Added by Florian Rival about 5 years ago. Updated almost 5 years ago.

Status:
Closed
Priority:
Must have
Assignee:
-
Category:
-
Target version:
-
Start date:
2015-09-07
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
6.2
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

It's impossible to add tasks with Typo3 6.2.14

How to reproduce :
. click on 'Scheduler'
. Add a task

The tasks won't be added because a mandatory field "lastexecution_failure" in the database is not filled. This field musn't be mandatory.
See here : https://review.typo3.org/#/c/41994/2/

There is also a second issue when this one is corrected, you cannot add an 'enable' task.
While default value for field 'disable' is set to 0 by default, the code set it to empty so there is an error, see below :

"Incorrect integer value: '' for column 'disable' at row 1"

#1

Updated by Florian Rival about 5 years ago

Florian Rival wrote:

It's impossible to add tasks with Typo3 6.2.14

How to reproduce :
. click on 'Scheduler'
. Add a task

The tasks won't be added because a mandatory field "lastexecution_failure" in the database is not filled. This field musn't be mandatory.
See here : https://review.typo3.org/#/c/41994/2/

There is also a second issue when this one is corrected, you cannot add an 'enable' task.
While default value for field 'disable' is set to 0 by default, the code set it to empty so there is an error, see below :

"Incorrect integer value: '' for column 'disable' at row 1"

I found the solution, this happens because mysql runs in strict mode : STRICT_TRANS_TABLES.
When strict mode is disabled, everything works fine.

#2

Updated by Steffen Müller almost 5 years ago

  • Project changed from Logging Project to TYPO3 Core
  • Is Regression set to No
#3

Updated by Riccardo De Contardi almost 5 years ago

  • Status changed from New to Closed

So, I think it is safe to close this, as TYPO3 does not support STRICT mode, see:

https://github.com/TYPO3/TYPO3.CMS/blob/TYPO3_6-2/INSTALL.md
https://github.com/TYPO3/TYPO3.CMS/blob/master/INSTALL.md

If you think that this is the wrong decision or experience this issue again, then please write to the mailing list typo3.teams.bugs with issue number and an explanation or open a new ticket and add a relation to this ticket number.

Also available in: Atom PDF