Bug #69815

Filemount folder selection always shows directories of the first storage

Added by Nicole Cordes over 4 years ago. Updated over 2 years ago.

Status:
Closed
Priority:
Should have
Assignee:
Category:
-
Target version:
Start date:
2015-09-15
Due date:
% Done:

100%

TYPO3 Version:
7
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

Due to the FormEngine changes the database row has resolved properties and as the base field is a select box an array is returned. We have to adjust the itemsProcFunc to get its information from the array instead expecting a string.

Associated revisions

Revision 4adbc635 (diff)
Added by Nicole Cordes over 4 years ago

[BUGFIX] Adjust itemsProcFunc for sys_filemounts

Due to the changes of FormEngine the folder selection of filemount
records always show the folders from fileadmin. This patch adjust the
script to handle the incoming (already resolved) database information.

Resolves: #69815
Releases: master
Change-Id: I395920088a32d39b4ffc46d768ef581c9ca42a8e
Reviewed-on: http://review.typo3.org/43321
Reviewed-by: Michael Oehlhof <>
Reviewed-by: Christian Kuhn <>
Tested-by: Christian Kuhn <>
Tested-by: Michael Oehlhof <>
Reviewed-by: Wouter Wolters <>
Tested-by: Wouter Wolters <>

History

#1 Updated by Gerrit Code Review over 4 years ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/43321

#2 Updated by Gerrit Code Review over 4 years ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/43321

#3 Updated by Nicole Cordes over 4 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#4 Updated by Anja Leichsenring over 4 years ago

  • Sprint Focus deleted (On Location Sprint)

#5 Updated by Riccardo De Contardi over 2 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF