Bug #70501

Cropping a png with transparency looses transparency

Added by Simon Schaufelberger about 4 years ago. Updated almost 4 years ago.

Status:
Closed
Priority:
Must have
Assignee:
-
Category:
Frontend
Target version:
-
Start date:
2015-10-08
Due date:
% Done:

0%

TYPO3 Version:
7
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

Uploading a png with transparency in a normal image content element and then cropping it looses its transparency. Transparency becomes black in my case. Using graphicsmagic.

test-transp.png View (3.59 KB) Riccardo De Contardi, 2015-11-01 22:22

History

#1 Updated by Riccardo De Contardi almost 4 years ago

I am using the latest 7.6-dev (master), and Graphicsmagick 1.3.21 (I am using a MAC enviroment with Homebrew) and the transparency has been preserved after cropping the image using the cropping tool of version 7

I also attach the image used for testing.

Could you check again? Thank you!

#2 Updated by Riccardo De Contardi almost 4 years ago

  • Category set to Frontend

#3 Updated by Simon Schaufelberger almost 4 years ago

does not appear again in latest master 7.6.1.

#4 Updated by Riccardo De Contardi almost 4 years ago

  • Status changed from Needs Feedback to Closed

I think I can close this, then.

If you think that this is the wrong decision or experience this issue again, then please write to the mailing list typo3.teams.bugs with issue number and an explanation or open a new ticket and add a relation to this ticket number.

Also available in: Atom PDF