Bug #70610

PropertyMapper directly throws TargetNotFoundException

Added by Mathias Brodala about 4 years ago. Updated over 3 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Extbase
Target version:
-
Start date:
2015-10-12
Due date:
% Done:

0%

TYPO3 Version:
6.2
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

Since TYPO3 6.2.15 the PropertyMapper directly throws a TYPO3\CMS\Extbase\Property\Exception\TargetNotFoundException if thrown by a type converter instead of encapsulating it once with a general TYPO3\CMS\Extbase\Property\Exception just like before.

This is a change in behavior and affects all code which relied on the previous structure to trigger e.g. the regular pageNotFoundHandling of TYPO3.


Related issues

Related to TYPO3 Core - Bug #55861: New PropertyMapper must accept not found arguments Closed 2014-02-11

History

#1 Updated by Mathias Schreiber about 4 years ago

  • Target version deleted (next-patchlevel)

#2 Updated by Mathias Brodala over 3 years ago

  • Status changed from New to Closed
  • Assignee deleted (Mathias Brodala)
  • Is Regression changed from Yes to No

This issue actually is none. The API of PropertyMapper::convert() states that it may throw exceptions of type TYPO3\CMS\Extbase\Property\Exception. Since TYPO3\CMS\Extbase\Property\Exception\TargetNotFoundException derives from that exception type, any catch statement for the former will also cover the latter. Thus no API breakage after all.

Also available in: Atom PDF