Bug #70906

Missing dependencies & suggests when installing extensions via Composer

Added by David Lemaitre over 4 years ago. Updated over 3 years ago.

Status:
Rejected
Priority:
Must have
Assignee:
-
Category:
System/Bootstrap/Configuration
Target version:
-
Start date:
2015-10-21
Due date:
% Done:

0%

TYPO3 Version:
6.2
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

In TYPO3 6.2, I installed media & vidi extensions via Composer. But vidi is loaded after media in the PackageStates.php file. In the ext_emconf.php file of media extension, I notice vidi dependency & suggests are missing.

You can compare this file with the one in the github repo : https://github.com/fabarea/media/blob/3.7.0/ext_emconf.php

History

#1 Updated by Wouter Wolters over 4 years ago

  • Status changed from New to Needs Feedback

How does this work for you in a 7.5 installation?

Composer integration is not complete in 6.2

#2 Updated by David Lemaitre over 4 years ago

Wouter Wolters wrote:

How does this work for you in a 7.5 installation?

Composer integration is not complete in 6.2

vidi & media extensions require typo3 6.2, cant install via composer.

#3 Updated by Helmut Hummel about 4 years ago

  • Category changed from composer to 1499
  • Status changed from Needs Feedback to Accepted

David Lemaitre wrote:

vidi & media extensions require typo3 6.2, cant install via composer.

This has nothing to do with a composer install. If you download the extensions via TER, the same problem occurs.

It is because the PackageManager in 6.2 uses a composer.json file to extract dependencies in favor of ext_emconf.php files. Since media has no dependencies on the such composer.json file, this information is not used during dependency ordering of the PackageStates.php file.

Question is, whether we should fix this in 6.2 or tell people to move on to 7.6 and not use composer.json for extensions in 6.2

#4 Updated by Gerrit Code Review about 4 years ago

  • Status changed from Accepted to Under Review

Patch set 1 for branch TYPO3_6-2 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/46031

#5 Updated by Gerrit Code Review about 4 years ago

Patch set 1 for branch TYPO3_6-2 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/46356

#6 Updated by Gerrit Code Review about 4 years ago

Patch set 2 for branch TYPO3_6-2 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/46356

#7 Updated by Gerrit Code Review almost 4 years ago

Patch set 1 for branch TYPO3_6-2 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/48076

#8 Updated by Nicole Cordes over 3 years ago

  • Status changed from Under Review to Rejected

Meanwhile there are updated versions of the extensions, compatible with 7.6. I don't see any reason to change the current composer behaviour in 6.2. IMHO there would be more trouble with such a patch. Therefore I decided to reject this ticket.

Also available in: Atom PDF