Bug #71655

Irre elemets in plugin configuration not possible

Added by Nicole Cordes almost 4 years ago. Updated almost 2 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
FormEngine aka TCEforms
Target version:
Start date:
2015-11-18
Due date:
% Done:

100%

TYPO3 Version:
7
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

It isn't possible to add an irre field with the plugin flexform configuration.

This is because the \TYPO3\CMS\Backend\Form\FormDataProvider\TcaFlexFetch receives insufficient database row information and don't get the correct ds structure in \TYPO3\CMS\Backend\Form\FormDataProvider\TcaFlexFetch::initializeDataStructure


Related issues

Duplicates TYPO3 Core - Bug #71436: Inline in flex with multiple DS fails Closed 2015-11-09

Associated revisions

Revision 570e19ed (diff)
Added by Morton Jonuschat almost 4 years ago

[BUGFIX] FormEngine: Select correct FlexForm DS for inline records

If an inline field is defined within a FlexForm that has multiple data
structures defined the FormAjaxInlineController always selects the
default data structure due to missing context information.

This patch transmits the required context within the AJAX request to
enable selecting the appropriate data structure for the flexform.

It also changes the method to determine the path through the flexform
data structure to work in the case of an inline element configured
within a flexform within another inline element.

Resolves: #71436
Related: #70918
Related: #71564
Related: #71655
Releases: master
Change-Id: I7ecd174b78997ad3b1d1513a15a78cdc7bac23ff
Reviewed-on: https://review.typo3.org/44914
Tested-by: Armin Ruediger Vieweg <>
Tested-by: Sebastian Michaelsen <>
Tested-by: Felix Rauch <>
Reviewed-by: Claus Due <>
Tested-by: Christopher Orth <>
Tested-by: Torsten <>
Tested-by: Philipp Wrann <>
Reviewed-by: Andreas Fernandez <>
Tested-by: Andreas Fernandez <>
Reviewed-by: Wouter Wolters <>
Tested-by: Wouter Wolters <>

History

#1 Updated by Christian Kuhn almost 4 years ago

  • Status changed from New to Resolved

resolved as dupe of #71436

#2 Updated by Christian Kuhn almost 4 years ago

  • % Done changed from 0 to 100

#3 Updated by Riccardo De Contardi almost 2 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF