Bug #71783

Adding FAL images in FlexForm is not possible

Added by Christopher Orth about 4 years ago. Updated about 1 year ago.

Status:
Closed
Priority:
Must have
Assignee:
-
Category:
FormEngine aka TCEforms
Target version:
-
Start date:
2015-11-23
Due date:
% Done:

100%

TYPO3 Version:
7
PHP Version:
5.6
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

Because of #68045 is tagged with 6.2 LTS and I am not sure this issue is related to that report here's a new issue for the similar Bug.
Actual it is not possible to use FAL images in 7 LTS in FlexForm for me. Trying to add an image with the following FlexForm returns a 500 Server error with the attached Stacktrace.

<settings.media>
    <TCEforms>
        <label>Image</label>
        <config>
            <type>inline</type>
            <minitems>0</minitems>
            <maxitems>1</maxitems>
            <appearance type="array">
                <createNewRelationLinkTitle>LLL:EXT:cms/locallang_ttc.xlf:media.addFileReference</createNewRelationLinkTitle>
                <enabledControls type="array">
                    <delete>1</delete>
                    <dragdrop>1</dragdrop>
                    <hide>1</hide>
                    <info>1</info>
                    <localize>1</localize>
                </enabledControls>
                <headerThumbnail type="array">
                    <field>uid_local</field>
                    <height>45c</height>
                    <width>45</width>
                </headerThumbnail>
                <useSortable>1</useSortable>
                <showAllLocalizationLink>0</showAllLocalizationLink>
                <showPossibleLocalizationRecords>0</showPossibleLocalizationRecords>
                <showRemovedLocalizationRecords>0</showRemovedLocalizationRecords>
                <showSynchronizationLink>0</showSynchronizationLink>
            </appearance>
            <foreign_field>uid_foreign</foreign_field>
            <foreign_label>uid_local</foreign_label>
            <foreign_match_fields type="array">
                <fieldname>media</fieldname>
            </foreign_match_fields>
            <foreign_selector>uid_local</foreign_selector>
            <foreign_selector_fieldTcaOverride type="array">
                <config type="array">
                    <appearance type="array">
                        <elementBrowserAllowed></elementBrowserAllowed>
                        <elementBrowserType>file</elementBrowserType>
                    </appearance>
                </config>
            </foreign_selector_fieldTcaOverride>
            <foreign_sortby>sorting_foreign</foreign_sortby>
            <foreign_table>sys_file_reference</foreign_table>
            <foreign_table_field>tablenames</foreign_table_field>
        </config>
    </TCEforms>
</settings.media>

stacktrace.html View (8.66 KB) Christopher Orth, 2015-11-23 12:20


Related issues

Duplicates TYPO3 Core - Bug #71436: Inline in flex with multiple DS fails Closed 2015-11-09

History

#1 Updated by Morton Jonuschat about 4 years ago

  • Category set to FormEngine aka TCEforms
  • Status changed from New to Resolved
  • % Done changed from 0 to 100

Resolved as dupe of #71436

#2 Updated by Benni Mack about 1 year ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF