Bug #71985

RTE classes requires doesn't work in LinkHandler

Added by Andreas Allacher over 6 years ago. Updated almost 5 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Link Handling, Site Handling & Routing
Target version:
Start date:
2015-11-30
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
7
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:
Stabilization Sprint

Description

Since 7.5 it is possible to use require to e.g. define RTE linkhandler classes like "btn btn-primary" by creating a class btn-primary and using requires to add the btn class.


Related issues

Related to TYPO3 Core - Feature #51905: Manage multiple classes attribution inside RTEClosed2013-09-11

Actions
#1

Updated by Andreas Allacher over 6 years ago

I meant 7.0 not 7.5 (at least I think it was 7.0)

#2

Updated by Andreas Allacher over 6 years ago

The issue also seems to have existed with 7.5 and therefore the bug is not part of the LinkHandler modifications done by Markus.
Apparantly support for "requires" only works with textstyle and blockstyle but not linkhandler.
However, it should also work with linkhandler.

#3

Updated by Andreas Allacher over 6 years ago

To fix the adding the class would be using Dom.addClass(node, cur_class) in TYPO3Link.js
However, the issue is the selector would have to display the correct class also.

#4

Updated by Frank Naegler over 6 years ago

  • Subject changed from RTE classes requires doesn't work to RTE classes requires doesn't work in LinkHandler
  • Target version changed from Candidate for patchlevel to 7.6.1
  • Sprint Focus set to Stabilization Sprint
#5

Updated by Frank Naegler over 6 years ago

  • Status changed from New to Accepted
  • Assignee deleted (Mathias Schreiber)
#6

Updated by Gerrit Code Review over 6 years ago

  • Status changed from Accepted to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/45172

#7

Updated by Gerrit Code Review over 6 years ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/45172

#8

Updated by Anonymous over 6 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100
#9

Updated by Riccardo De Contardi almost 5 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF