Bug #72116

Files without references still show a warning before deleting

Added by Lorenz Ulrich about 4 years ago. Updated almost 4 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
-
Target version:
-
Start date:
2015-12-09
Due date:
% Done:

0%

TYPO3 Version:
6.2
PHP Version:
5.4
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

I have some files in the File module that have no references with is correctly shown in the list:

When I look at the detail view of the file, I see a reference nevertheless - the reference from the sys_file_metadata record to this file:

Now when I'm trying to delete this file, which is never used in content, I still get the warning that there is one reference:

I assume that the problem is that the JavaScript dialog is based on the total number of references without considering that every file has a sys_file_metadata record.

file-reference-1.png View (52.2 KB) Lorenz Ulrich, 2015-12-09 09:48

file-reference-3.png View (16.1 KB) Lorenz Ulrich, 2015-12-09 09:48

file-reference-2.png View (9.47 KB) Lorenz Ulrich, 2015-12-09 09:48

History

#1 Updated by Frans Saris about 4 years ago

  • Status changed from New to Needs Feedback

sys_file_metadata relations are currently hardcoded excluded. Could you maybe update the refindex and check again.

#2 Updated by Riccardo De Contardi almost 4 years ago

  • Status changed from Needs Feedback to Closed

The problem seems fixed in 7.6.4 as far as I can see; moreover there has been no feedback within the last 90 days => so, I am closing this issue for now.

If you think that this is the wrong decision or experience this issue again, then please write to the mailing list typo3.teams.bugs with issue number and an explanation or open a new ticket and add a relation to this ticket number.

Also available in: Atom PDF