Bug #72337

Epic #72333: Clean up charset conversion and language service

Merge TYPO3_CONF_VARS[t3lib_cs_convMethod] and [t3lib_cs_utils]

Added by Benni Mack over 3 years ago. Updated 10 months ago.

Status:
Closed
Priority:
Should have
Assignee:
Category:
-
Target version:
-
Start date:
2015-12-31
Due date:
% Done:

100%

TYPO3 Version:
7
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

As they are always set to the same option, this options can be merged. A new option "CharsetConverter" should be used to define the parameters directly. This is also to get rid of t3lib_cs_*


Subtasks

Task #72497: Remove recode support for csConvClosedBenni Mack


Related issues

Related to TYPO3 Core - Task #76366: Remove unused HTML templates in Install Tool Closed 2016-05-29

Associated revisions

Revision 384db09a (diff)
Added by Benni Mack over 3 years ago

[FEATURE] Auto-detect charset conversion

The CharsetConverter previously had to be configured
to detect if mbstring or iconv or TYPO3's homemade code
via the $TYPO3_CONF_VARS options.

Since CharsetConverter is now a singleton, the check
which conversion strategy should be chosen is now done
during runtime once every request, where mbstring
takes precedence over iconv.

The feature detection in the Install Tool is removed.

Resolves: #72337
Releases: master
Change-Id: Iaa34ed9db2faec0eda9606a399541e564499baa3
Reviewed-on: https://review.typo3.org/45663
Reviewed-by: Georg Ringer <>
Tested-by: Georg Ringer <>

History

#1 Updated by Gerrit Code Review over 3 years ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/45663

#2 Updated by Gerrit Code Review over 3 years ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/45663

#3 Updated by Gerrit Code Review over 3 years ago

Patch set 3 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/45663

#4 Updated by Benni Mack over 3 years ago

  • Status changed from Under Review to Resolved

#5 Updated by Benni Mack 10 months ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF