Bug #72382

Symlinking i.e. uploads folder not "allowed" according to Install Tool

Added by Claus Harup over 6 years ago. Updated over 6 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
-
Target version:
-
Start date:
2015-12-22
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
6.2
PHP Version:
5.6
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

My uploads folder contains Giga bytes of data, so to save expensive SS storage I symlinked the folder to external NAS storage.

Upgrading from 4.5 to 6.2 going through the Install Tool the "Folder structure" section gives me the following error message:

/uploads is not a directory - Directory /uploads should be a directory, but is of type link

Going through the source code I found in \TYPO3\CMS\Install\FolderStructure\DirectoryNode:

protected function isDirectory() {
$path = $this->getAbsolutePath();
return (@is_link($path) && @is_dir($path));
}

The above gives me an error in the Install Tool - nevertheless it still works (of course). Should it not be possible to symlink any folder in TYPO3???


Files


Related issues

Is duplicate of TYPO3 Core - Bug #57706: Install tool marking symlinked directories as errors.Closed2014-04-07

Actions
#1

Updated by Georg Ringer over 6 years ago

  • Status changed from New to Closed

closed as being a duplicate of #57706

Also available in: Atom PDF