Bug #72548

Cannot install: phpwhois/idna-convert cannot be downloaded

Added by Mathias Brodala almost 4 years ago. Updated about 1 year ago.

Status:
Closed
Priority:
Must have
Category:
composer
Target version:
Start date:
2016-01-06
Due date:
% Done:

100%

TYPO3 Version:
7
PHP Version:
Tags:
Complexity:
Is Regression:
Yes
Sprint Focus:

Description

The Github repository of the package phpwhois/idna-convert is somehow gone which makes every Composer installation of TYPO3 fail:

  - Installing phpwhois/idna-convert (v0.8.2)
    Downloading
    Failed to download phpwhois/idna-convert from dist: The "https://api.github.com/repos/phpWhois/idna-convert/zipball/ea337954b43ae47f5ebba97c19d309081bebc46e" file could not be downloaded (HTTP/1.1 404 Not Found)
    Now trying to download from source
  - Installing phpwhois/idna-convert (v0.8.2)
    Cloning ea337954b43ae47f5ebba97c19d309081bebc46e

  [RuntimeException]                                                                                                               
  Failed to clone git@github.com:phpWhois/idna-convert.git via git, https, ssh protocols, aborting.                                
  - git://github.com/phpWhois/idna-convert.git                                                                                     
    Cloning into '/.../vendor/phpwhois/idna-convert'...  
    fatal: remote error:                                                                                                           
      Repository not found.                                                                                                        
  - https://github.com/phpWhois/idna-convert.git                                                                                   
    Cloning into '/.../vendor/phpwhois/idna-convert'...  
    remote: Invalid username or password.                                                                                          
    fatal: Authentication failed for 'https://github.com/phpWhois/idna-convert.git/'                                               
  - git@github.com:phpWhois/idna-convert.git                                                                                       
    Cloning into '/.../vendor/phpwhois/idna-convert'...  
    Warning: Permanently added 'github.com,192.30.252.129' (RSA) to the list of known hosts.                                       
    Permission denied (publickey).                                                                                                 
    fatal: Could not read from remote repository.                                                                                  

    Please make sure you have the correct access rights                                                                            
    and the repository exists.                                                                                                     

I am currently investigating the options since the whole issue is a mess.

Associated revisions

Revision 05941cb6 (diff)
Added by Mathias Brodala almost 4 years ago

[TASK] Replace abandoned IDNA converter

The package "phpwhois/idna-convert" was abandoned in favor of
the package "mso/idna-convert".

Change-Id: Ie5bb7be899b6810d825a019b62cbc326521f8018
Resolves: #72548
Releases: master, 7.6
Reviewed-on: https://review.typo3.org/45632
Reviewed-by: Wouter Wolters <>
Tested-by: Wouter Wolters <>
Reviewed-by: Markus Klein <>
Tested-by: Markus Klein <>

Revision 0c49700a (diff)
Added by Mathias Brodala almost 4 years ago

[TASK] Replace abandoned IDNA converter

The package "phpwhois/idna-convert" was abandoned in favor of
the package "mso/idna-convert".

Change-Id: Ie5bb7be899b6810d825a019b62cbc326521f8018
Resolves: #72548
Releases: master, 7.6
Reviewed-on: https://review.typo3.org/45668
Reviewed-by: Markus Klein <>
Tested-by: Markus Klein <>

History

#1 Updated by Mathias Brodala almost 4 years ago

The repository at https://github.com/phpWhois/idna-convert has been restored by the author now. There are no releases in that repository anymore but Composer will simply fall back to cloning via Git to download the packages.

The author suggests switching to mso/idna-convert instead:

I haven't noticed that typo3 might depend on this package.

Let me check if I can restore this repository.

However the original packagist package provided by the author of library is mso/idna-convert. TYPO3 maintainers should change the name of the package I believe.

I've asked the author of that package to make a stable release. Sascha Egerer already did a source diff and there are no noteworthy changes which could be breaking.

#2 Updated by Gerrit Code Review almost 4 years ago

  • Status changed from In Progress to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/45632

#3 Updated by Gerrit Code Review almost 4 years ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/45632

#4 Updated by Gerrit Code Review almost 4 years ago

Patch set 3 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/45632

#5 Updated by Gerrit Code Review almost 4 years ago

Patch set 1 for branch TYPO3_7-6 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/45668

#6 Updated by Mathias Brodala almost 4 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#7 Updated by Benni Mack about 1 year ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF