Bug #72875

htmlArea RTE: JS error is raised when using the delete icon on a flexform

Added by Kay Röseler about 4 years ago. Updated about 4 years ago.

Status:
Closed
Priority:
Must have
Assignee:
-
Category:
RTE (rtehtmlarea + ckeditor)
Target version:
Start date:
2009-02-18
Due date:
% Done:

0%

TYPO3 Version:
6.2
PHP Version:
Tags:
Complexity:
easy
Is Regression:
No
Sprint Focus:

Description

When trying to delete an element of a flexform that contains a RTE-enabled field, a js error "illegal character" is raised.

see https://forge.typo3.org/issues/19803 and https://forge.typo3.org/issues/20045

From TYPO3 6.2.16this mistake appears again, because here the function has changed again and only easy quotation marks contain.

Same bugfix as in https://forge.typo3.org/issues/19803.

rtehtmlarea_bugfix_10479.patch View (1.14 KB) Administrator Admin, 2009-02-18 19:16

patch_RteHtmlAreaBase.php.patch View - Patch for RteHtmlAreaBase.php (1.32 KB) Kay Röseler, 2016-01-21 17:48


Related issues

Related to TYPO3 Core - Bug #19803: Section with RTE - delete isn't possible because of JS-Error Closed 2009-01-12
Related to TYPO3 Core - Bug #20045: htmlArea RTE: JS error is raised when using the delete icon on a flexform Closed 2009-02-18

History

#1 Updated by Wouter Wolters about 4 years ago

  • Status changed from New to Needs Feedback

Did you try this on latest 6.2.17 ?
Should be fixed with https://review.typo3.org/#/c/45356/

#2 Updated by Kay Röseler about 4 years ago

Yesterday it works neither with 6.2.16, nor with 6.2.17. Today it works with 6.2.17. Strangely, but bug entry can closed.

#3 Updated by Wouter Wolters about 4 years ago

  • Status changed from Needs Feedback to Closed

Thanks for reporting back. It was a small regression in the security patch that has been fixed within 6.2.17.

Also available in: Atom PDF