Bug #72952

REVERT Introduce DeprecationUtility and move methods

Added by Frank Naegler over 3 years ago. Updated almost 2 years ago.

Status:
Closed
Priority:
Must have
Assignee:
Category:
Code Cleanup
Target version:
Start date:
2016-01-26
Due date:
% Done:

100%

TYPO3 Version:
8
PHP Version:
Tags:
Complexity:
Is Regression:
Yes
Sprint Focus:

Description

The patch https://review.typo3.org/#/c/46159/ must be reverted. (issue: #67269)
The patch contains one problem with logDeprecatedFunction call.
Also we decided to not move this methods because it will be incredible hard or at least annoying for ext devs to deprecate own functionality with this API change.


Related issues

Related to TYPO3 Core - Task #67269: Introduce DeprecationUtility and move methods Rejected 2015-06-03

Associated revisions

Revision 3855c5c2 (diff)
Added by Frank Naegler over 3 years ago

Revert "[TASK] Introduce DeprecationUtility and move methods"

The patch contains one problem with logDeprecatedFunction call.
Also we decided to not move this methods because it will be incredible
hard or at least annoying for ext devs to deprecate own functionality
with this API change.

This reverts commit a155401a6fab5b90ca3f8a41a4edb4b5ea4ad5e6.

Change-Id: I2ce0e967a070b5c41d09870399fabe8e8d341fe9
Releases: master
Resolves: #72952
Reverts: #67269
Reviewed-on: https://review.typo3.org/46250
Reviewed-by: Frank Naegler <>
Tested-by: Frank Naegler <>

History

#1 Updated by Gerrit Code Review over 3 years ago

  • Status changed from Accepted to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/46250

#2 Updated by Gerrit Code Review over 3 years ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/46250

#3 Updated by Gerrit Code Review over 3 years ago

Patch set 3 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/46250

#4 Updated by Gerrit Code Review over 3 years ago

Patch set 4 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/46250

#5 Updated by Frank Naegler over 3 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#6 Updated by Riccardo De Contardi almost 2 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF