Bug #73628

Fluid f:link.page doesn't accept additionalAttributes and data-*

Added by Morton Jonuschat over 5 years ago. Updated over 5 years ago.

Status:
Closed
Priority:
Should have
Category:
Fluid
Target version:
Start date:
2016-02-23
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
8
PHP Version:
7.0
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

When using the fluid linkviewhelper for pages with additionalAttributes or data the result is an exception that says an unregistered argument is being used.

Example code that triggers bug:

<f:link.page pageUid="{item.link}" additionalAttributes="{draggable:'false'}">

Related issues

Is duplicate of TYPO3 Core - Bug #73432: Ensure additionalAttributes for tagbased viewhelperClosedNicole Cordes2016-02-15

Actions
#1

Updated by Gerrit Code Review over 5 years ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/46842

#2

Updated by Wouter Wolters over 5 years ago

  • Status changed from Under Review to Closed

A duplicate of #73432

Also available in: Atom PDF