Bug #73714

Executing extbase commands as schedule task broken

Added by Nicole Cordes over 4 years ago. Updated about 3 years ago.

Status:
Closed
Priority:
Should have
Assignee:
Category:
-
Target version:
Start date:
2016-02-27
Due date:
% Done:

100%

TYPO3 Version:
8
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

Currently it isn't possible to execute any extbase command as scheduler task. All tasks exit with PHP Warning: array_shift() expects parameter 1 to be array, null given in vendor\symfony\console\Input\ArgvInput.php line 59


Related issues

Related to TYPO3 Core - Task #73152: Update Symfony Console to 3.x Closed 2016-02-05

Associated revisions

Revision c062b630 (diff)
Added by Nicole Cordes over 4 years ago

[BUGFIX] Executing Extbase commands as scheduler task

Currently the execution of all Extbase commands as scheduler task
exits with a warning due to wrong parameter input type. This patch
ensures the object is initialized only if needed and a correct CLI
context is available.

Resolves: #73714
Releases: master
Change-Id: I869b1fe9e8440885f4cfb6fb0570ca98334494a1
Reviewed-on: https://review.typo3.org/46928
Reviewed-by: Wouter Wolters <>
Tested-by: Wouter Wolters <>
Reviewed-by: Benni Mack <>
Tested-by: Benni Mack <>

History

#1 Updated by Gerrit Code Review over 4 years ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/46928

#2 Updated by Gerrit Code Review over 4 years ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/46928

#3 Updated by Gerrit Code Review over 4 years ago

Patch set 3 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/46928

#4 Updated by Gerrit Code Review over 4 years ago

Patch set 4 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/46928

#5 Updated by Nicole Cordes over 4 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#6 Updated by Riccardo De Contardi about 3 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF