Project

General

Profile

Actions

Bug #75334

closed

RTE: Lists from Word pasted in Editor are not converted to HTML List

Added by Online Now! GmbH over 8 years ago. Updated over 7 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
RTE (rtehtmlarea + ckeditor)
Target version:
-
Start date:
2016-03-31
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
6.2
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

We noticed in TYPO3 6.2 and 7 if you copy a unordered or ordered list from a word document ( 2013 and 2016 tested ) and paste it into the RTE, the list wont be recognized as a list and will be converted to paragraphs with nbsp spaces. As far we can remember this worked in the past. Other editors like ckeditor or tinymce are handling this without a problem.

Actions #1

Updated by Online Now! GmbH over 8 years ago

Just tested this with OpenOffice 4.1.2 and there is no problem with pasting a list in the editor ( besides the text in each list element is wrapped in a paragraph ).

Actions #2

Updated by Riccardo De Contardi about 8 years ago

  • Status changed from New to Needs Feedback

Hi,
I just tested with TYPO3 6.2.25 and 7.6.9 and Word 2010 for windows, and I was not able to reproduce the problem; after pasting a simple list from Word, the HTML becomes:

<ul style="margin-top:0cm" type="disc"> 
  <li class="MsoNormal">Prova</li> 
  <li class="MsoNormal">Prova</li> 
  <li class="MsoNormal">Prova</li> 
  <li class="MsoNormal">Prova</li> 
  <li class="MsoNormal">prova</li> 
</ul>
Actions #3

Updated by Riccardo De Contardi about 8 years ago

with Word 2015 for MAC, the html pasted is:

<p><span style="font-family:Symbol">·<span style="font-stretch: normal; font-size: 7pt; font-family: 'Times New Roman'; ">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; </span></span>Prova</p>
<p><span style="font-family:Symbol">·<span style="font-stretch: normal; font-size: 7pt; font-family: 'Times New Roman'; ">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; </span></span>Prova</p>
<p><span style="font-family:Symbol">·<span style="font-stretch: normal; font-size: 7pt; font-family: 'Times New Roman'; ">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; </span></span>Prova</p>
<p><span style="font-family:Symbol">·<span style="font-stretch: normal; font-size: 7pt; font-family: 'Times New Roman'; ">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; </span></span>Prova</p>

Actions #4

Updated by Alexander Opitz over 7 years ago

  • Status changed from Needs Feedback to Closed

This is a typical issue from MS Word.

With TYPO3 8 LTS we will switch to CKEditor, till then you may use one of the RTE Clean Extensions (rtepasteplain).

So will close this issue.

Actions

Also available in: Atom PDF