Project

General

Profile

Actions

Bug #75465

closed

"Show Content from Page" shows no content

Added by Manfred Rutschmann almost 8 years ago. Updated over 7 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Frontend
Target version:
Start date:
2016-04-08
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
7
PHP Version:
5.6
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

This bug is reproducible. You need a TYPO3 installation with 7.6.4, FE rendering with FLUIDTEMPLATE, the first page with content and the second page without content.
Set "Show Content from Page" in the second page with the first page as selected source. Content on the first page is showing, content on the second page is not showing.

Contact me if you need access to a running dev project.

Actions #1

Updated by Riccardo De Contardi almost 8 years ago

can this be related, too? https://forge.typo3.org/issues/18534

Actions #2

Updated by Daniel Goerz almost 8 years ago

  • Status changed from New to Needs Feedback
  • Priority changed from Must have to Should have

Cannot reproduce this. I am testing with mountpoints and fluid_styled_content.

Page1 has content.
Page2 is a mountpoint with "Show Content from selected page" and page1 selected. It has no content of its own.

In the frontend both sites show the same content as expected.

Please add more information on how to reproduce your issue.

Keep in mind that for mountpoints to work you need to set enable_mount_pids to true in the install tool (which is the default but one never knows ...)

Actions #3

Updated by Daniel Goerz over 7 years ago

  • Status changed from Needs Feedback to Closed

I tested again without mountpoints by just setting "show content from page" in the page properties the 2nd page. It works in 7LTS and in master as well. The content from page 1 is rendered on page 2 as it would be expected.

Since there was no feedback since the opening of this ticket, I close it.

If there still is a bug in the core please reopen the ticket or open a new ticket with concrete steps to reproduce, so we can see what the problem might be.

A wild guess would be: You are using VHS to render the content with the VHS view helper and there the "show content from page" setting is not respected there. This is just a guess and I did not check what the VHS view heper does.

Actions

Also available in: Atom PDF