Bug #75670

CLI Dispatcher broken in 7.6.x

Added by Philipp Idler almost 4 years ago. Updated almost 4 years ago.

Status:
Closed
Priority:
Must have
Assignee:
-
Category:
-
Target version:
-
Start date:
2016-04-15
Due date:
% Done:

100%

TYPO3 Version:
7
PHP Version:
5.6
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

When I execute an scheduler task in command via CLI in TYPO3 7.6.5 I get:

> typo3/cli_dispatch.phpsh extbase help
Oops, an error occurred: This script must have a command as first argument.

With TYPO3 7.6.4 I get:

PHP Warning: array_shift() expects parameter 1 to be array, null given in /html/typo3/typo3_src-7.6.4/vendor/symfony/console/Input/ArgvInput.php line 61

Seems like something is broken with CLI dispatcher in 7.6.x

History

#1 Updated by Wouter Wolters almost 4 years ago

Can't reproduce this on my dev system. Can you try to dig a bit deeper into the problem?
Maybe try an empty installation and run the command.

#2 Updated by Philipp Idler almost 4 years ago

  • % Done changed from 0 to 100

Yup, is solved.
I had to put an interpreter in front:

php_cli ./typo3/cli_dispatch.phpsh extbase help

Ticket can be closed

#3 Updated by Wouter Wolters almost 4 years ago

  • Status changed from New to Closed

Thanks for reporting back. Will close the ticket now.

Also available in: Atom PDF