Bug #75757

FAL: Exception thrown if image for youtube video can't be fetched

Added by Stephan GroƟberndt over 3 years ago. Updated 12 months ago.

Status:
Closed
Priority:
Must have
Assignee:
-
Category:
File Abstraction Layer (FAL)
Target version:
-
Start date:
2016-04-18
Due date:
% Done:

100%

TYPO3 Version:
8
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

If you add a youtube video in the file list and (in my case apparently due to wifi connection problems) the image for the video can't be fetched the FileList view dies with an exception:

Uncaught TYPO3 Exception: cURL error 28: Resolving timed out after 10572 milliseconds (see http://curl.haxx.se/libcurl/c/libcurl-errors.html) | GuzzleHttp\Exception\ConnectException thrown in file /var/www/dev-master.local.typo3.org/vendor/guzzlehttp/guzzle/src/Handler/CurlFactory.php in line 186. Requested URL: http://dev-master.local.typo3.org/typo3/index.php?M=file_FilelistList&moduleToken=6c88c02377ef9f173eb222e90c7eb5fc0d3dd791&id=1%3A%2Ftestfolder%2F

Related issues

Related to TYPO3 Core - Feature #70056: Use guzzle Closed 2015-09-23

Associated revisions

Revision 5af25891 (diff)
Added by Christoph Kratz over 3 years ago

[BUGFIX] Catch RequestException in GeneralUtility::getUrl()

When a request in getUrl() fails (e.g. due to exceeded time limit, host
misconfiguration) Guzzle throws an exception.

This patch restores the behaviour of getUrl() before using Guzzle by
catching the exception.

Resolves: #75757
Releases: master
Change-Id: Iedc36cce48eaee85beeb7c448b546dc3a49034d0
Reviewed-on: https://review.typo3.org/47779
Reviewed-by: Wouter Wolters <>
Reviewed-by: Philipp Gampe <>
Tested-by: Philipp Gampe <>
Reviewed-by: Nicole Cordes <>
Tested-by: Nicole Cordes <>

History

#1 Updated by Gerrit Code Review over 3 years ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/47779

#2 Updated by Gerrit Code Review over 3 years ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/47779

#3 Updated by Gerrit Code Review over 3 years ago

Patch set 3 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/47779

#4 Updated by Gerrit Code Review over 3 years ago

Patch set 4 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/47779

#5 Updated by Gerrit Code Review over 3 years ago

Patch set 5 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/47779

#6 Updated by Gerrit Code Review over 3 years ago

Patch set 6 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/47779

#7 Updated by Christoph Kratz over 3 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#8 Updated by Benni Mack 12 months ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF