Bug #75887

GeneralUtility::copyDirectory doesn't fix windows paths

Added by Jigal van Hemert almost 5 years ago. Updated almost 2 years ago.

Status:
Closed
Priority:
Should have
Category:
-
Target version:
-
Start date:
2016-04-23
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
8
PHP Version:
Tags:
Complexity:
easy
Is Regression:
No
Sprint Focus:

Description

While iterating a directory the resulting SplFileInfo object produce paths with windows directory separators. These are now passed to upload_copy_move without fixing the directory separators.
Furthermore an SplFileInfo object is passed to upload_copy_move instead of a string (which the function signature requires). Because of PHP type juggling this is converted to a string which happens to result in the path and name of the file.

#1

Updated by Gerrit Code Review almost 5 years ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/47879

#2

Updated by Jigal van Hemert about 2 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100
#3

Updated by Benni Mack almost 2 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF