Bug #76224

State change notifications not send when option „Notify all users on any change“ is not set (workspaces)

Added by Christian Richter about 3 years ago. Updated about 3 years ago.

Status:
New
Priority:
Should have
Assignee:
-
Category:
Workspaces
Start date:
2016-05-18
Due date:
% Done:

0%

TYPO3 Version:
7
PHP Version:
5.5
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

When a user sends a change to another stage, a notification mail only gets send when the change is moved to the LIVE-Workspace.

Our Setup:

One additional Workspace that we call "PREVIEW Workspace"
Some BE Users are Owners in the User-Tab, some BE Users are Members in the User-Tab.

We have three stages editing, ready to publish and publishing execute.
By default, only if a change is moved to publishing execute a notification mail get's send.
I can check and uncheck the respective Owners and Members on each stagechange, but no mail gets send.
If I enable the option „Notify all users on any change“ I can check and uncheck Owners and Members on each stage-change and the respective notification-mails are send.
Only checked Users are getting notifications, no matter which status they have (Member/Owner).

So from my point of view everything is working fine when „Notify all users on any change“ is set, but the name of the option made me think that indeed ALL USERS are notified on ANY CHANGE without respecting my manual restrictions/selections.

workspace_users.png View (39.9 KB) Christian Richter, 2016-05-18 14:53

option_set.png View (111 KB) Christian Richter, 2016-05-18 14:53

checkboxes.png View (101 KB) Christian Richter, 2016-05-18 14:53

History

#1 Updated by Oliver Hader about 3 years ago

Can you please add a screenshot of the relevant configuration of the workspace record? This way it's easier to ensure we're talking about the same behavior. Thanks in advance...

Also available in: Atom PDF