Project

General

Profile

Actions

Bug #76614

closed

In 8.1.2 Fe-eId requests fail for logged in users

Added by Gisèle Wendl over 7 years ago. Updated over 7 years ago.

Status:
Closed
Priority:
Must have
Assignee:
-
Category:
Frontend
Target version:
Start date:
2016-06-13
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
8
PHP Version:
7.0
Tags:
eID, feUserInit, getPageRepository
Complexity:
Is Regression:
No
Sprint Focus:

Description

With TYPO3 8.1.2 I get errors with AJAX-requests using eID.
$GLOBALS['TSFE']->initFEuser(); ends up in an error:
"Return value of TYPO3\CMS\Core\Database\Query\QueryContext::getPageRepository() must be an instance of TYPO3\CMS\Frontend\Page\PageRepository, string returned"

Call is made in TYPO3\CMS\Core\Database\Query\QueryContext::getPageRepository(), line 348 by $this->includePlaceholders = $this->getPageRepository()->versioningPreview;

It happens after a user made login.
Logout does not always help - deleting the cookies does.

Site with problem is https://812.toctoc.ch
Almost same site, with TYPO3 8.0.1 - but no problem with eID - is https://80.toctoc.ch.

DBAL has no influence on this, neither if workspaces are used or not.

To me it looks like some "spaghetti-problem" resulting from the current work on the concerned code in core.


Files

Actions #1

Updated by Susanne Moog over 7 years ago

  • Status changed from New to Needs Feedback

Hi,

I currently cannot reproduce the issue. Can you provide a test extension to trigger the error? Can you additionally try if the error also occurs on current master?

Thanks!

Susi

Actions #2

Updated by Gisèle Wendl over 7 years ago

Hello,
You can try reproduce it with ext:toctoc_comments 9.1.0, FF Firebug works nice to see the Ajax-Posts and the server replies.
How to wget the current master?

Thanks :-)

Actions #3

Updated by Gisèle Wendl over 7 years ago

We are a step ahead, I found time to investigate and the result is as follows:

With TYPO3 8.2.1 the AJAX-requests using eID with fe_user logged in - the
$GLOBALS['TSFE']->initFEuser();
does work.

With TYPO3 8.1.2 the AJAX-requests using eID with fe_user logged in - the
$GLOBALS['TSFE']->initFEuser();
does NOT work, as described in the Bug-Description

Proposition: I will add TYPO3 8.1.2 to the "conflicts with"-List in ext_emconf.php in next version of toctoc_comments (9.2.0) ... and "Status: Closed" please :-)

Actions #4

Updated by Riccardo De Contardi over 7 years ago

  • Status changed from Needs Feedback to Closed

I think I can close it as resolved, as 8.1.x is no more supported.

If you think that this is the wrong decision or you experience the issue again, please open a new issue with a reference to this one. Thank you

Actions

Also available in: Atom PDF