Project

General

Profile

Actions

Bug #76695

closed

Linking images via typoscript to hidden pages results in click-enlarge

Added by Julian Krzefski almost 8 years ago. Updated about 7 years ago.

Status:
Closed
Priority:
Must have
Assignee:
-
Category:
Frontend
Target version:
Start date:
2016-06-19
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
7
PHP Version:
5.5
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

When an IMAGE-object gets a typolink-property via TS to a hidden page, the link is not rendered as a normal link but automatically becomes a click-enlarge-link for that image. Seems to be related to this bug: #16161. But this affects the current 7.6.9 version.

Actions #1

Updated by Riccardo De Contardi over 7 years ago

  • Status changed from New to Needs Feedback

Hi. Could you give me an example about how to reproduce it with version 8 ? Thank you!

Actions #2

Updated by Riccardo De Contardi about 7 years ago

I am not able to reproduce it with 7.6.15 or the latest master 8.6-dev, so I close it.

My test:

Ts setup:

page.11 = IMAGE
page.11.file = fileadmin/Images/image.jpg
// Let's resize the original image
page.11.file.width = 200
// Of course uid=17 is an hidden page
page.11.stdWrap.typolink.parameter = 17

Note: on 8.6-dev (latest master) I used page.11.stdWrap.typolink.parameter = t3://page?uid=17

Results:

No link wraps the image.

If you think that this is the wrong decision or experience the issue again or that a different test should be performed, please reopen it or open a new issue with a reference to this one.

Thank you.

Actions #3

Updated by Riccardo De Contardi about 7 years ago

  • Status changed from Needs Feedback to Closed
Actions

Also available in: Atom PDF