Bug #76906

Protected property sword disables possiblity to use hook

Added by Claus Harup over 4 years ago. Updated about 2 years ago.

Status:
Closed
Priority:
Must have
Assignee:
-
Category:
Indexed Search
Target version:
Start date:
2016-07-01
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
7
PHP Version:
7.0
Tags:
Complexity:
easy
Is Regression:
No
Sprint Focus:
On Location Sprint

Description

Having:

$GLOBALS['TYPO3_CONF_VARS']['EXTCONF']['indexed_search']['pi1_hooks']['initialize_postProc'] = 'XXXXXXX\TxExtension\Hooks\IndexedsearchHook';

and

function initialize_postProc() {
    if(GeneralUtility::_GP('q')){
        $this->pObj->sword = GeneralUtility::_GP('q');
    }
}

leaves me with an error because the property sword is protected :-(

#1

Updated by Tymoteusz Motylewski about 4 years ago

  • Complexity set to easy
#2

Updated by Tymoteusz Motylewski about 4 years ago

  • Sprint Focus set to On Location Sprint
#3

Updated by Gerrit Code Review about 4 years ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/50127

#4

Updated by Gerrit Code Review about 4 years ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/50127

#5

Updated by Gerrit Code Review about 4 years ago

Patch set 3 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/50127

#6

Updated by Gerrit Code Review about 4 years ago

Patch set 4 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/50127

#7

Updated by Michał Jankiewicz about 4 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100
#8

Updated by Benni Mack about 2 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF