Bug #76935

Link Browser: Selecting records fails in record list view

Added by Robert Heinig over 4 years ago. Updated about 4 years ago.

Status:
Closed
Priority:
Must have
Assignee:
-
Category:
-
Target version:
-
Start date:
2016-07-05
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
7
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

The extension "linkhandler" allows to extends the link browser to select arbitrary records by creating new tabs within the link browser and integrating the regular record list view.
The selection of records fails after clicking the "show more" button of the record list view. The visible text within the input of the corresponding backend form link element changes, but the value of the hidden input element does not change to the value of the selected record.

The reason for this behavior is, that the "show more" button reloads the link browser and the function of "FormEngineLinkBrowserAdapter.updateFunctions" is empty.
That´s caused by a failed comparison of fieldChangeFuncHash when calling LinkBrowserController::areFieldChangeFunctionsValid().
The hash comparison fails, because in the process of generating the URI of the read more button GeneralUtility::implodeArrayForUrl() is called with $skipBlank = true, while the hash, which was copied from the request, was generated with the empty parameter "alert", so when checking the hash this parameter does no longer exist.

I think a good solution to avoid this problem is to not add the empty "alert" parameter in the first place, see the attached patch.


Files

SingleFieldContainer.php.patch (842 Bytes) SingleFieldContainer.php.patch Robert Heinig, 2016-07-05 10:12

Related issues

Is duplicate of TYPO3 Core - Bug #75743: Linkhandler values not stored if selected record has been searched for or paginated toClosedMarkus Klein2016-04-18

Actions
#1

Updated by Markus Klein about 4 years ago

  • Status changed from New to Closed

Thanks very much for the report and the patch. Unfortunately I didn't get a notification about your report earlier.
It is a duplicate unfortunately and I found the very same solution as well.

Please push patches directly to Gerrit in the future.

Closing this one now as duplicate.

Also available in: Atom PDF