Bug #77242

Serialization of 'Closure' is not allowed (in context with direct_mail_subscription)

Added by Wiebke Lauke about 5 years ago. Updated over 3 years ago.

Status:
Closed
Priority:
-- undefined --
Category:
-
Target version:
-
Start date:
2016-07-25
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
6.2
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

Hi there,

when I use a plugin direct_mail_subscription and above a content element text/image on a page in the same colPos I get an error "Serialization of 'Closure' is not allowed".

When I change the position of the plugin direct_mail_subscription the page loads without exception.

TYPO3: 6.2.25
direct_mail_subscription: 2.0.3
direct_mail: 4.1.0

Thanks in advance!


Files

t3_exception_closure.png (407 KB) t3_exception_closure.png Wiebke Lauke, 2016-07-25 16:47
#1

Updated by Alexander Opitz over 3 years ago

  • Status changed from New to Needs Feedback

Hi,

does the problem still exists within newer versions of TYPO3 CMS (7.6.23 or 8.6.9)?

#2

Updated by Wiebke Lauke over 3 years ago

Alexander Opitz wrote:

Hi,

does the problem still exists within newer versions of TYPO3 CMS (7.6.23 or 8.6.9)?

Hi,

I did not test that. At the moment the problem exists only in TYPO3 6.2.

#3

Updated by Alexander Opitz over 3 years ago

So I would close this issue for now, as 6.2 is out of support. You could then report a new issue and reference this one, if you encounter this issue in newer versions. Ok?

#4

Updated by Wiebke Lauke over 3 years ago

Alexander Opitz wrote:

So I would close this issue for now, as 6.2 is out of support. You could then report a new issue and reference this one, if you encounter this issue in newer versions. Ok?

And what about extended TYPO3 6.2 support? We bought that. Shouldn't there be a solution for it? :)

#5

Updated by Anja Leichsenring over 3 years ago

  • Assignee set to Anja Leichsenring

I will do an assessment for the issue in 6.2, but on first sight that sounds rather like an issue in ext:direct_mail_subscription.
Please be aware, that ELTS support will not extend to extensions.

#6

Updated by Anja Leichsenring over 3 years ago

Hi Wiebke,

I tried my best to reproduce the issue.

Here are my system settings:

first:
- PHP Version 5.6.32-1+ubuntu16.04.1+deb.sury.org+2
- latest ELTS 6.2.35
- direct_mail 4.1.0
- direct_mail_subscription 2.0.4 (latest for 6.2)
- css_styled_content

second:
- PHP Version 5.6.32-1+ubuntu16.04.1+deb.sury.org+2
- latest ELTS 6.2.35
- direct_mail 4.1.0
- direct_mail_subscription 2.0.4 (latest for 6.2)
- bootstrap_package

third:
- PHP Version 5.3.29 (hosted on jweiland)
- latest ELTS 6.2.35
- direct_mail 4.1.0
- direct_mail_subscription 2.0.4 (latest for 6.2)
- css_styled_content

I created CE text with image and plugin direct_mail_subscription on the same colPos.
But, for none of the mentioned setups, I was able to reproduce the Exception.
Can you tell me anything else that might be different for you, so I can try again?

#7

Updated by Wiebke Lauke over 3 years ago

Hi Anja,

after deactivating gridelements extension everything works fine. So it's not a bug with just direct_mail_subscription rather with gridelements and direct_mail_subscription.
So it's not up to u to fix it.

You can close this ticket. Maybe Jo Hasenau can help :)

Thank you for testing!

Greetz,
Wiebke

#8

Updated by Anja Leichsenring over 3 years ago

  • Status changed from Needs Feedback to Closed
  • Priority changed from Should have to -- undefined --

Hello Wiebke,

thank you for the update. I will close the ticket as requested.

Kind regards
Anja

Also available in: Atom PDF