Bug #77321

Similar Behaviour of mapping error as described in Bug #66952

Added by Dorit Rottner almost 5 years ago. Updated almost 5 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
-
Target version:
-
Start date:
2016-08-01
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
6.2
PHP Version:
5.6
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

We have extended the fe_users table and mapped it the following way

config.tx_extbase {
    persistence {
        classes {
            Tx_PtEubBase_Domain_Model_FrontendUser {
                mapping {
                    tableName = fe_users
                    recordType = Tx_Extbase_Domain_Model_FrontendUser
                }
            }

            Tx_Extbase_Domain_Model_FrontendUser {
                mapping {
                   tableName = fe_users
                   columns {
                       lockToDomain.mapOnProperty = lockToDomain
                   }
                }
            }
        }
    }
}

We get on our Production System the error that table "Tx_Extbase_Domain_Model_FrontendUser" does not extist. This happens randomly. Cleaning cache with Install tool helps. We are monitoring the system and can see that when it happens System is working correct again some time later.

We can't produce the error on the Testsystem.

We are using TYPO3 Version 6.2.26. The same code worked with no problem on TYPO3 4.5


Related issues

Is duplicate of TYPO3 Core - Bug #75399: Extbase: Class/Table Mapping doesn't work sometimesAcceptedMarkus Klein2016-04-04

Actions
#1

Updated by Wouter Wolters almost 5 years ago

  • Status changed from New to Closed

Duplicates #75399

#2

Updated by Wouter Wolters almost 5 years ago

Please continue in #75399

Also available in: Atom PDF