Bug #77374

Opposite MM relation between both new entities not created

Added by Oliver Hader about 3 years ago. Updated 12 months ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Workspaces
Target version:
-
Start date:
2016-08-03
Due date:
% Done:

100%

TYPO3 Version:
7
PHP Version:
5.5
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

Scenario:
  • usage in a workspace
  • tt_content and sys_category records are created at the same time with defining an MM relation
  • sys_category.items (group/db field, with MM and opposite usage defined) is filled with accordant tt_content record
Problem:
  • the remap-stack in DataHandler does not consider references that are defined in a group/db field
  • thus, these kind of relations are just not set, since the opposite reference uid cannot be resolved
Solution:
  • process group/db relations with new record uids in remap-stack

Associated revisions

Revision 988d96d7 (diff)
Added by Oliver Hader about 3 years ago

[BUGFIX] Opposite MM relation between both new entities not created

Scenario:
  • usage in a workspace
  • tt_content and sys_category records are created at the same time
    with defining an MM relation
  • sys_category.items (group/db field, with MM and opposite usage
    defined) is filled with accordant tt_content record
Problem:
  • the remap-stack in DataHandler does not consider references that
    are defined in a group/db field
  • thus, these kind of relations are just not set, since the opposite
    reference uid cannot be resolved
Solution:
  • process group/db relations with new record uids in remap-stack

Resolves: #77374
Releases: master, 7.6
Change-Id: If5e6589e2a0995dc4fce3ff49bd309f2fdb6eb24
Reviewed-on: https://review.typo3.org/49337
Tested-by: Bamboo TYPO3com <>
Reviewed-by: Christian Kuhn <>
Reviewed-by: Oliver Hader <>
Tested-by: Oliver Hader <>

Revision eee0e85e (diff)
Added by Oliver Hader about 3 years ago

[BUGFIX] Opposite MM relation between both new entities not created

Scenario:
  • usage in a workspace
  • tt_content and sys_category records are created at the same time
    with defining an MM relation
  • sys_category.items (group/db field, with MM and opposite usage
    defined) is filled with accordant tt_content record
Problem:
  • the remap-stack in DataHandler does not consider references that
    are defined in a group/db field
  • thus, these kind of relations are just not set, since the opposite
    reference uid cannot be resolved
Solution:
  • process group/db relations with new record uids in remap-stack

Resolves: #77374
Releases: master, 7.6
Change-Id: If5e6589e2a0995dc4fce3ff49bd309f2fdb6eb24
Reviewed-on: https://review.typo3.org/49337
Reviewed-on: https://review.typo3.org/49352
Reviewed-by: Oliver Hader <>
Tested-by: Oliver Hader <>

History

#1 Updated by Gerrit Code Review about 3 years ago

  • Status changed from New to Under Review

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/49337

#2 Updated by Gerrit Code Review about 3 years ago

Patch set 3 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/49337

#3 Updated by Gerrit Code Review about 3 years ago

Patch set 1 for branch TYPO3_7-6 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/49352

#4 Updated by Oliver Hader about 3 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#5 Updated by Benni Mack 12 months ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF