Bug #77489

curl: respect ssl_* settings without curlProxyServer=1

Added by Jochen Weber over 4 years ago. Updated over 2 years ago.

Status:
Closed
Priority:
-- undefined --
Assignee:
-
Category:
System/Bootstrap/Configuration
Target version:
-
Start date:
2016-08-12
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
7
PHP Version:
Tags:
Complexity:
easy
Is Regression:
No
Sprint Focus:

Description

Hi all.

if ['SYS']['curlUse'] is true and ['SYS']['curlProxyServer'] is false, the ['HTTP']['ssl_*']-Settings are not respected.

The lines from 2480 to 2489 (7.6.10) should be moved after line 2472.

greets, jochen


Related issues

Is duplicate of TYPO3 Core - Bug #75908: Respect ssl_verify_peer, ssl_verify_host and ssl_capath settings for curl requests not only in case of using curlProxyServerRejectedPetra Arentzen2016-04-25

Actions
#1

Updated by Jochen Weber over 4 years ago

The line-numbers are for the file "GeneralUtility.php"

#2

Updated by Gerrit Code Review over 3 years ago

  • Status changed from New to Under Review

Patch set 1 for branch TYPO3_7-6 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/53543

#3

Updated by Oliver Hader over 3 years ago

Can you please describe the use case in more detail please.
The SSL settings have been put like this on purpose in issue #75038
Thanks in advance for your feedback

#4

Updated by Benjamin Kluge over 3 years ago

One usage are: I want to set a custom ca-file and or an ca-path for internal server communication without setting a proxy.
Other usage: It should be possible to set the verify peer to false (without setting proxy), we've a internal server with a custom certificate

#5

Updated by Alexander Opitz over 2 years ago

  • Is duplicate of Bug #75908: Respect ssl_verify_peer, ssl_verify_host and ssl_capath settings for curl requests not only in case of using curlProxyServer added
#6

Updated by Alexander Opitz over 2 years ago

  • Status changed from Under Review to Closed

Closing this as duplicate of #75908

Also available in: Atom PDF