Bug #77893

Viewhelper syntax should be whitespace tolerant

Added by Jörg Wagner almost 5 years ago. Updated almost 3 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Fluid
Target version:
-
Start date:
2016-09-09
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
7
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

Any viewhelper property will not work if you add whitespace around an equal sign that joins a property name and its value.

Examples:
<f:render partial="List/Item" /> is OK
<f:render partial ="List/Item" /> is DEFUNCT
<f:render partial= "List/Item" /> is DEFUNCT

As an XML language Fluid should be tolerant to such whitespaces in its assignments.
Integrators will add these whitespaces easily and may debug for hours to find the cause of the resulting malfunction. (At least I did. :)

#1

Updated by Claus Due almost 5 years ago

Suggested as fix for standalone Fluid. The TYPO3 7.6 LTS branch will need a similar patch to be implemented.

See: https://github.com/TYPO3Fluid/Fluid/pull/140

#2

Updated by Claus Due almost 5 years ago

  • % Done changed from 0 to 100

Can be solved by upgrading the Fluid dependency to 1.0.10

#3

Updated by Claus Due almost 5 years ago

  • Status changed from New to Resolved

Resolved since upgrading Fluid dependency to 1.0.10 (currently at 1.1.1 awaiting 2.0.0)

#4

Updated by Benni Mack almost 3 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF