Bug #77970

Indexing external files with path longer than 255 chars

Added by Robert Vock about 3 years ago. Updated about 1 year ago.

Status:
Closed
Priority:
Must have
Assignee:
-
Category:
Indexed Search
Target version:
-
Start date:
2016-09-16
Due date:
% Done:

100%

TYPO3 Version:
6.2
PHP Version:
5.6
Tags:
Complexity:
Is Regression:
No
Sprint Focus:
On Location Sprint

Description

It's not possible to index external files when their path is longer than 255 characters long.

This happens because the field index_phash.data_filename is only a varchar(255). It would be good to increase the size of this field.

Bug appears in TYPO3 6.2.27, but the size of the field hasn't changed in 7.6 or 8, so I believe the bug will be present there as well.


Related issues

Related to TYPO3 Core - Bug #78149: Change field definition for caption and copyright in sys_file_metadata Closed 2016-10-05

Associated revisions

Revision c28041d7 (diff)
Added by Karol Lamparski about 3 years ago

[BUGFIX] Change Indexed Search index_phash.data_filename column length

Make database field index_phash.data_filename longer, because varchar(255) was not enough for some URLs.

Resolves: #77970
Releases: master, 7.6
Change-Id: I6cea9c2f9debecbf482bc78cd4a2867d8f9c5e47
Reviewed-on: https://review.typo3.org/50126
Tested-by: TYPO3com <>
Reviewed-by: Tomasz Stępniak <>
Tested-by: Tomasz Stępniak <>
Reviewed-by: Tymoteusz Motylewski <>
Tested-by: Tymoteusz Motylewski <>

Revision 53e5e7ba (diff)
Added by Karol Lamparski about 3 years ago

[BUGFIX] Change Indexed Search index_phash.data_filename column length

Make database field index_phash.data_filename longer, because varchar(255) was not enough for some URLs.

Resolves: #77970
Releases: master, 7.6
Change-Id: I6cea9c2f9debecbf482bc78cd4a2867d8f9c5e47
Reviewed-on: https://review.typo3.org/50144
Tested-by: TYPO3com <>
Reviewed-by: Tymoteusz Motylewski <>
Tested-by: Tymoteusz Motylewski <>

History

#1 Updated by Karol Lamparski about 3 years ago

  • Sprint Focus set to On Location Sprint

#2 Updated by Gerrit Code Review about 3 years ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/50126

#3 Updated by Gerrit Code Review about 3 years ago

Patch set 1 for branch TYPO3_7-6 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/50144

#4 Updated by Karol Lamparski about 3 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#5 Updated by Benni Mack about 1 year ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF