Bug #78063

No default DB engine set for multiple tables

Added by Silvia Bigler about 5 years ago. Updated almost 5 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
-
Target version:
-
Start date:
2016-09-26
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
7
PHP Version:
5.6
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

The table sys_file_reference and many other have no defined engine. So depending on the MySQL setup, they might be created as MyISAM tables.
It happened that the table sys_file_reference crashed, so TYPO3 did not work anymore until the table was repaired.

This could probably be prevented by changing the tables to InnoDB.

#1

Updated by Stephan Großberndt about 5 years ago

We use TokuDB as main engine. I would rather not have InnoDB to be forced for more tables. I propose to rather configure your server differently to use InnoDB as default engine instead.

#2

Updated by Morton Jonuschat about 5 years ago

  • Status changed from New to Needs Feedback

I agree with Stephan on this, unless there is a requirement to force a certain engine type (like full text search) the database system should be the one that decides on the best defaults.
Given that InnoDB is the default engine since MySQL 5.5 and TYPO3 requires MySQL 5.5+ I don't see a big problem with keeping things the way they are.

#3

Updated by Riccardo De Contardi almost 5 years ago

  • Status changed from Needs Feedback to Closed

90 days without feedback => closing this issue

If you think that this is the wrong decision or it is still relevant, please reopen it or open a new issue with a reference to this one.

Thank you

Also available in: Atom PDF