Bug #78101

Epic #77810: Improve (responsive) image handling

Aspect ratio is not kept when cropping wizard is closed

Added by Sascha Egerer almost 3 years ago. Updated over 2 years ago.

Status:
Rejected
Priority:
Should have
Assignee:
-
Category:
Backend User Interface
Start date:
2016-09-28
Due date:
% Done:

0%

TYPO3 Version:
7
PHP Version:
Tags:
Complexity:
easy
Is Regression:
No
Sprint Focus:
Remote Sprint

Description

Steps to reproduce:

  1. Add a image relation to a content element
  2. open the cropping wizard
  3. select an aspect ratio and select your image area
  4. close the wizard
  5. open the wizard again

Expected result:

The selected ratio is kept and if i change the selected area the ratio is still respected

Current result:

The ratio is not respected anymore. Changing the selected area is now in "free mode". Clicking the aspect ratio again results in a "new selected are" so the "old" information is lost.

The selected ratio should be stored in the JSON and not just the selected area.

History

#1 Updated by Sascha Egerer almost 3 years ago

  • Description updated (diff)

#2 Updated by Riccardo De Contardi almost 3 years ago

  • Category set to Backend User Interface

#3 Updated by Helmut Hummel over 2 years ago

  • Status changed from New to Needs Feedback

close the wizard

You mean pressing accept? Then I cannot reproduce.
You mean pressing cancel? Then nothing is saved (which is the case for me)

#4 Updated by Sascha Egerer over 2 years ago

  • Status changed from Needs Feedback to Rejected

Could not reproduce anymore.

Also available in: Atom PDF