Bug #78622

hide/unhide Button does not work in inline context

Added by Stefan Froemken over 4 years ago. Updated over 3 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
FormEngine aka TCEforms
Target version:
Start date:
2016-11-09
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
7
PHP Version:
5.6
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

Hello Core-Team,

normal records:

if I go into the list module I have the possibility to click on hide/unhide-Button. When clicking on this button an AJAX-Request was send and my record was updated:

Inline records:

Go into list module again and open a tt_content record containing some images. Now click on the hide button of one of the images. In console there is no AJAX-Request anymore. The record was not updated. The inline record will only be saved, if you save the parent record, too.

I miss some consistence here. The button is and acts the same, so I expect that it does the same. We have 3 different save-buttons? Why? Because they act different.

I prefer to find another Icon for hide/unhide button in inline context OR it modifies the record as expected.

What do you think about such a change?

Stefan

#1

Updated by Frank Naegler almost 4 years ago

1) I think this not a bug, but maybe a feature request
2) The behavior is correct, because you edit here a complete record. If you have finished your changes, you click on the save button, and your changes are persisted, else you would change the content record only to x% ... example: you replace an image and the text which is related to the image, then your text say: The following picture shows a monkey, but the images shows a horse...
3) Another icon: clearly no :) One function/state = one icon ... with 7 and 8 we streamlined all icons and removes a lot of duplicated icons.

From my point of view, this issue should be closed.

#2

Updated by Frank Naegler almost 4 years ago

  • Status changed from New to Needs Feedback
#3

Updated by Stefan Froemken over 3 years ago

  • Status changed from Needs Feedback to Closed

This issue was a question from one of our customers. Currently I don't remember this customer anymore. So I close this issue now.

Also available in: Atom PDF