Bug #78657

getRegisteredFlexForms in AbstractItemProvider throws not catched exceptions

Added by Christian Kuhn over 5 years ago. Updated over 5 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
-
Target version:
-
Start date:
2016-11-11
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
8
PHP Version:
Tags:
Complexity:
nightmare
Is Regression:
No
Sprint Focus:

Description

Affects be_group editing:

If a DS is registered that manipulates the flex form DS retrieval, resolving in getRegisteredFlexForms() may fail. Example scenario is a loaded ext:gridelements that doesn't register a default flex DS.

This code part is used to enable flex form data access right settings, and the current code needs to do a "qualified guess". It probably can only be systematically solved with either a flex form ds registry, or a convention based magic system, or a hook.

For now, we should probably just catch a possible extension at that point and ignore those cases for the flex field access right system.

Solving this case systematically would have the advantage that we might be able to do stuff like static TCA migration for flex DS, too, so in general that would be interesting to have.


Related issues

Related to TYPO3 Core - Task #78581: Refactor flex form data structure handlingClosed2016-11-05

Actions
Is duplicate of TYPO3 Core - Bug #78852: Opening be_groups records may throw exceptionClosed2016-12-01

Actions

Also available in: Atom PDF