Project

General

Profile

Actions

Bug #78701

closed

The source language is wrong determined for copied record translations

Added by Gleb Levitin over 7 years ago. Updated about 7 years ago.

Status:
Closed
Priority:
Must have
Assignee:
-
Category:
Backend User Interface
Target version:
Start date:
2016-11-15
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
8
PHP Version:
7.0
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

How to reproduce:

Imagine, you have a single record with translation.

Now copy this record into a new page and add a new content element to the default language column.

Now click "Translate" button in the target language column.

The element to be translated (New record) is not displayed in the records summary, but the already translated record (Text & Media Datensatz).

Technical problem description:

TYPO3 uses t3_origuid to determine, which language the translated records were originally derived from. In the case of a simple translation, t3_origuid is actually the UID of the record from which it was translated. However, t3_origuid is not only limited to this single function, but extends to many other types of derivation.

If a translated record is copied, the t3_origuid of the copied translated record will get the UID of the original translation, but not the original record itself.

Now, when creating new translations within the copied data set, the source language will be wrong determined and the already existing translated records will now be translated in the same language again.


Files


Related issues 1 (0 open1 closed)

Is duplicate of TYPO3 Core - Bug #78599: Copy localized content element leads to wrong reference, translation failsClosedMarkus Mächler2016-11-07

Actions
Actions #1

Updated by Gleb Levitin over 7 years ago

  • Description updated (diff)
Actions #2

Updated by Gleb Levitin over 7 years ago

  • Subject changed from Wrong source language for copied records to The source language is wrong determined for copied record translations
Actions #4

Updated by Gleb Levitin about 7 years ago

  • Status changed from New to Closed
Actions #5

Updated by Gleb Levitin about 7 years ago

  • Assignee deleted (Gleb Levitin)
Actions

Also available in: Atom PDF