Bug #78830

images attached to record in workspace get removed when published to live

Added by Christian Eßl about 3 years ago. Updated over 2 years ago.

Status:
Closed
Priority:
Should have
Category:
Workspaces
Target version:
-
Start date:
2016-11-29
Due date:
% Done:

0%

TYPO3 Version:
7
PHP Version:
5.6
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

Hi,

we discovered a scenario in which image attachments of a record, created in a workspace, get removed, when published to the live workspace.
I attached an example extension with just a dummy model and an image field. It appears to only happen with the TCA setting of type "group":

'image' => array(
'exclude' => 0,
'label' => 'LLL:EXT:dummy/Resources/Private/Language/locallang_db.xlf:tx_dummy_domain_model_dummy.image',
'config' => array(
'type' => 'group',
'internal_type' => 'file',
'uploadfolder' => 'uploads/tx_dummy',
'show_thumbs' => 1,
'size' => 1,
'maxitems' => 1,
'allowed' => $GLOBALS['TYPO3_CONF_VARS']['GFX']['imagefile_ext'],
'disallowed' => '',
),
),

To reproduce this problem, the following steps are required:
- install a new typo3 7.6.12
- install the "workspace" extension and the attached "dummy" extension
- create a root page and a workspace record "Test"
- switch to the workspace and create a new "dummy" record with an uploaded image attached.
- check the upload path "uploads/tx_dummy/filename.*" - the file should be there as expected
- go to the workspace module and publish the new record to LIVE
- now check the upload path again - file suddenly got removed and is nowhere else to be found
- if you now open the record in the list module, you will get a "File is missing!" error message.

dummy_0.0.0_201611291408.zip (509 KB) Christian Eßl, 2016-11-29 14:10

Schermata 2017-04-24 alle 23.14.28.png View (56.9 KB) Riccardo De Contardi, 2017-04-24 23:29

Schermata 2017-04-24 alle 23.18.17.png View (48.8 KB) Riccardo De Contardi, 2017-04-24 23:29

History

#1 Updated by Mathias Schreiber about 3 years ago

  • Status changed from New to Needs Feedback
  • Assignee set to Mathias Schreiber

Did you try using regular FAL relations?
The usage of internal type "file" is discouraged and should not be used any longer.

#2 Updated by Christian Eßl almost 3 years ago

That was the problem, I switched to FAL relations and it works now.
But this now leads to another workspace problem related to files. I will describe it with the default "media" field in pages:

- setup a typo3 7.6.*
- install the "workspace" extension and add a workspace record "Test"
- in LIVE, go to page properties and add an image relation to the "media" field.
- switch to the workspace and delete the same image reference from the "media" field.
- publish changes to LIVE

The removal of file relations appear to be ignored. While in the "Test" workspace, there now is no file relation, in "LIVE" the relation is still existing after publishing the changes.

#3 Updated by Riccardo De Contardi over 2 years ago

I close this one as I am not able to reproduce it anymore on version 7.6.16 or latest master (9.0.0-dev).

My test:

1) Create a "Custom Workspace" Workspace
2) LIVE workspace > create page "TEST 78830"
3) LIVE workspace > TEST 78830 > add CE "text & media"> add a relation to an image
4) Switch to "Custom Workspace" > edit the CE created at point 2) > delete the relation to the image > save
5) Workspace module > select the CE > "Choose staging action" > select "Publish to live"

Result: the image is removed in "live" workspace, even if in the workspace module you have not checked the line with the image removal (see attached screenshots). All worskpace changes are removed from the workspace.

If you think that this is the wrong decision or have more information or a different scenario about how to reproduce this issue, please reopen it or open a new issue with a reference to this one. Thank you.

Also available in: Atom PDF