Feature #78890

Allow inclusion of CSS into page footer

Added by Pascal Dürsteler almost 5 years ago. Updated about 4 years ago.

Status:
Rejected
Priority:
Should have
Assignee:
-
Category:
Frontend
Target version:
Start date:
2016-12-05
Due date:
% Done:

0%

Estimated time:
PHP Version:
Tags:
Complexity:
Sprint Focus:

Description

There are various PAGE properties and subproperties to manage javascript inclusion positioning (document header or before the closing body tag). It would be nice to also have the same possibilities for CSS, as in terms of optimizations, a project may only have an above-the-fold style and everything else is being loaded at the end of the page. At the moment, this is only possible with workarounds.


Related issues

Is duplicate of TYPO3 Core - Feature #78613: Add includeCSSFooter and includeCSSFooterlibs properties to pageClosed2016-11-08

Actions
#1

Updated by Mathias Schreiber almost 5 years ago

  • Tracker changed from Bug to Feature
  • Target version set to 8 LTS

I fail to see how this is a bug, so I'm changing this to feature.

#2

Updated by Mathias Schreiber almost 5 years ago

As a sidenote:
You could just copy how config.includeFooterJSLibs works and add config.includeFooterCSSLibs... done.

#3

Updated by Wouter Wolters almost 5 years ago

  • Status changed from New to Rejected

Duplicate of #78613

#4

Updated by Piotr Łojewski about 4 years ago

When when when pleeease for 7.6

Also available in: Atom PDF