Bug #79024

Exception in EXT:form due to invalid array lookup

Added by Oliver Hader almost 3 years ago. Updated about 2 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Form Framework
Target version:
Start date:
2016-12-18
Due date:
% Done:

100%

TYPO3 Version:
8
PHP Version:
7.0
Tags:
Complexity:
Is Regression:
No
Sprint Focus:
Stabilization Sprint

Description

Due to the changes of ArrayUtility in issue #77732 EXT:form now has to deal with these problems
  • core's ArrayUtility uses a slash as delimiter, Extbase's ArrayUtility used a dot
  • core's ArrayUtility throws an exception if value is not defined, Extbase's ArrayUtility returned null

Related issues

Related to TYPO3 Core - Task #77732: Deprecate Extbase's ArrayUtility Closed 2016-09-01

Associated revisions

Revision 25d53cc0 (diff)
Added by Oliver Hader almost 3 years ago

[BUGFIX] Exception in EXT:form due to invalid array lookup

Due to the changes of ArrayUtility in issue #77732
EXT:form now has to deal with these problems:

+ core's ArrayUtility uses a slash "/" as delimiter,
but Extbase's ArrayUtility used a dot "."
+ core's ArrayUtility throws an exception if value is
not defined, Extbase's ArrayUtility returned null

Change-Id: I26b043a28e376c99d50a9a36703b5927b09ee934
Resolves: #79024
Releases: master
Reviewed-on: https://review.typo3.org/50995
Tested-by: TYPO3com <>
Reviewed-by: Ralf Zimmermann <>
Tested-by: Ralf Zimmermann <>
Reviewed-by: Benni Mack <>
Reviewed-by: Christian Kuhn <>
Tested-by: Christian Kuhn <>

History

#1 Updated by Gerrit Code Review almost 3 years ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/50995

#2 Updated by Gerrit Code Review almost 3 years ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/50995

#3 Updated by Gerrit Code Review almost 3 years ago

Patch set 3 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/50995

#4 Updated by Gerrit Code Review almost 3 years ago

Patch set 4 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/50995

#5 Updated by Oliver Hader almost 3 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#6 Updated by Riccardo De Contardi about 2 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF