Bug #79039

Installation process hangs with PHP 7.1

Added by Oliver Hader almost 3 years ago. Updated about 1 year ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
-
Target version:
-
Start date:
2016-12-19
Due date:
% Done:

100%

TYPO3 Version:
8
PHP Version:
7.1
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

This behavior is kind of strange. During the installation process of TYPO3 CMS 8.5-dev (25d53cc07f991fbfed3ad96c86de5af52457af0a) the execution hangs if the doctrine Lexer instance is created. It seems to be a PHP 7.1 issue that could be reproduced with 7.1-RC5 and 7.1.0 on Mac OS.

Besides that, I've created a new PHP bug report: https://bugs.php.net/bug.php?id=73789

Associated revisions

Revision c4bfbd34 (diff)
Added by Oliver Hader almost 3 years ago

[TASK] Installation process hangs with PHP 7.1

The lengthy switch/case part of the Lexer class seems to be
too much for PHP 7.1.0. Albeit this seems to be a PHP bug,
this patch is provided to help others and to clean up the
mentioned switch/case code.

Change-Id: I0e8e4ca55f2e15d0445874b44a04742645670570
Resolves: #79039
Releases: master
Reviewed-on: https://review.typo3.org/50998
Tested-by: TYPO3com <>
Reviewed-by: Morton Jonuschat <>
Tested-by: Morton Jonuschat <>
Reviewed-by: Oliver Hader <>
Tested-by: Oliver Hader <>

History

#1 Updated by Gerrit Code Review almost 3 years ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/50998

#2 Updated by Gerrit Code Review almost 3 years ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/50998

#3 Updated by Oliver Hader almost 3 years ago

  • Description updated (diff)

#4 Updated by Oliver Hader almost 3 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#5 Updated by Benni Mack about 1 year ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF