Bug #79077

Wrong queryBuilder used when TSconfig option clearCache_pageSiblingChildren is used

Added by Wouter Wolters almost 3 years ago. Updated about 1 year ago.

Status:
Closed
Priority:
Should have
Category:
Database API (Doctrine DBAL)
Target version:
-
Start date:
2016-12-22
Due date:
% Done:

100%

TYPO3 Version:
8
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

Wrong queryBuilder used when TSconfig option clearCache_pageSiblingChildren is used

$siblingChildrenQuery must be used instead of $queryBuilder


Related issues

Related to TYPO3 Core - Task #78437: Refactor use of queryBuilder to use prepared statements Closed 2016-10-26

Associated revisions

Revision 9fbe40bf (diff)
Added by Wouter Wolters almost 3 years ago

[BUGFIX] Remove wrong queryBuilder usage in prepareCacheFlush

Due to a wrong queryBuilder being used the parameters stay empty.
Use the correct queryBuilder to prevent SQL errors.

Resolves: #79077
Releases: master
Change-Id: I62b28f7eeb0a1cc4d481e63a46f9784159116b6e
Reviewed-on: https://review.typo3.org/51024
Reviewed-by: Steffen Ritter <>
Tested-by: Steffen Ritter <>
Tested-by: TYPO3com <>
Reviewed-by: Oliver Hader <>
Tested-by: Oliver Hader <>

History

#1 Updated by Gerrit Code Review almost 3 years ago

  • Status changed from In Progress to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/51024

#2 Updated by Gerrit Code Review almost 3 years ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/51024

#3 Updated by Wouter Wolters almost 3 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#4 Updated by Benni Mack about 1 year ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF