Bug #79163

Workspace Preview (ADMCMD_prev=) failing for page with alias

Added by Peter Niederlag over 2 years ago. Updated 8 months ago.

Status:
Rejected
Priority:
Should have
Assignee:
-
Category:
Workspaces
Target version:
-
Start date:
2017-01-05
Due date:
% Done:

0%

TYPO3 Version:
6.2
PHP Version:
5.5
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

Description

As a Backend-User I generate a preview link in the workspace module in the backend.
I send this link to a collegue in order to let him/her preview the workspace content.

I expect the site to stay in workspace-preview-mode and show the content of the workspace when navigating in the frontend.

In general this works as expected, however on some pages the workspace content is NOT shown.

Analysis

Initial Preview-Link:
http://www.example.com/index.php?&ADMCMD_prev=8184198ureduineaa6078862ec23b718&id=711&L=1

The ADMCMD_prev value will make TYPO3 save a cookie with the very same value which is then evaluated by the FE and will have the effect that the workspace preview will be shown for any page.

However on pages with an alias the workspace content is not shown

This is a link generated in the menu:
http://www.example.com/index.php?id=someAlias&L=1

When we change someAlias to the numerical id of the page the updated workspace-content is shown/applied.

History

#1 Updated by Benni Mack 8 months ago

  • Status changed from New to Rejected

Hey Peter,

this feature has been superseded by the new Page-based URL slug handling. The field pages.alias had various drawbacks and will be removed in TYPO3 v10.0. If you still experience issues with the new handling, please open up a new ticket.

Thanks.
Benni.

Also available in: Atom PDF