Bug #79250

EXT:form - deactivating allowedFileMounts lets input fields for new form disappear

Added by Tobi Kretschmann almost 4 years ago. Updated about 2 years ago.

Status:
Closed
Priority:
Should have
Category:
Form Framework
Target version:
-
Start date:
2017-01-10
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
8
PHP Version:
7.0
Tags:
form
Complexity:
Is Regression:
No
Sprint Focus:

Description

If you overwrite the allowedFileMount in BaseSetup.yaml with null because you have activated the allowSaveToExtensionPaths, the wizard to create a new form does not show the input fields for Form name and advanced settings anymore.

TYPO3:
  CMS:
    Form:
      persistenceManager:
        allowedFileMounts:
          10: null
        allowSaveToExtensionPaths: true
        allowedExtensionPaths:
          100: EXT:myext/Resources/Private/Forms/

Files

extForm_noFields.PNG (7.34 KB) extForm_noFields.PNG Tobi Kretschmann, 2017-01-10 15:03
#1

Updated by Ralf Zimmermann almost 4 years ago

  • Assignee set to Ralf Zimmermann

Thanks for your feedback.
I fix this asap.

#2

Updated by Ralf Zimmermann almost 4 years ago

  • Category set to Form Framework
#3

Updated by Ralf Zimmermann almost 4 years ago

This is somewhat misleading.
"allowSaveToExtensionPaths" is intended to make existing forms within extension locations (defined by "allowedExtensionPaths") editable.
Currently this does not mean "Save new created forms to extension locations".
You want to to ensure that forms can no longer be stored in filemounts, but in extension locations.
I hacked some code to achive this.

With this patch is it possible to

  • save existing forms within extension locations ("allowedExtensionPaths") if "allowSaveToExtensionPaths" is set to true (like before)
  • save new created forms within extension locations ("allowedExtensionPaths") if "allowSaveToExtensionPaths" is set to true
  • delete forms within extension locations ("allowedExtensionPaths") if "allowDeleteFromExtensionPaths" is set to true

In addition, I've included bug fixes for the case if no paths are defined.
You can simply test the patchset with this little example extension:
https://code.tritum.de/TYPO3.CMS/ext_form_example1484079334

You can play around with this settings to test the behavior:
https://code.tritum.de/TYPO3.CMS/ext_form_example1484079334/blob/master/Configuration/Yaml/Backend.yaml#L7-8

#4

Updated by Gerrit Code Review almost 4 years ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/51254

#5

Updated by Gerrit Code Review almost 4 years ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/51254

#6

Updated by Tobi Kretschmann almost 4 years ago

Nice work. Thank you. It works perfectly :)

#7

Updated by Ralf Zimmermann almost 4 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100
#8

Updated by Benni Mack about 2 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF