Bug #79918

Opening links in pop-up windows no longer works

Added by Christer V over 2 years ago. Updated almost 2 years ago.

Status:
Closed
Priority:
Must have
Assignee:
-
Category:
Content Rendering
Target version:
Start date:
2017-02-20
Due date:
% Done:

100%

TYPO3 Version:
8
PHP Version:
7.0
Tags:
Complexity:
Is Regression:
No
Sprint Focus:
Stabilization Sprint

Description

After the rewrite of Css Styled Content, it's no longer possible to open links in pop up windows.

How to replicate.
  • Create a link
  • Set a external link
  • Set 500x500 as target

Expected behaviour is that the link opens in a new pop-up window with size 500x500. But currently the link just opens in a new tab.

The reason is that the typoscript was rewritten so that parameter.data = parameters:allParams was changed to parameter.data = parameters:href. This means that the link target doesn't get parsed by to resolveMixedLinkParameter, which means that TypoLinkCodecService->decode won't return the correct target.

Associated revisions

Revision 6e927aae (diff)
Added by Christer V over 2 years ago

[BUGFIX] Opening links in pop-up windows

Moved the check for if the target is coded as a JS open window link,
to a later stage in the function.

Since Css Styled Content and Fluid Styled Content was refactored,
the target might not be set until later in the typoLink
function. This caused pop links to stop working, moving the check for a
pop up link target to a later stages fixes the problem.

Resolves: #79918
Releases: master
Change-Id: Ie27fa3142df83c33ba3ad465ecb35c0f6e571f86
Reviewed-on: https://review.typo3.org/51830
Tested-by: TYPO3com <>
Reviewed-by: Anders Kostending <>
Reviewed-by: Faton Haliti <>
Reviewed-by: Jasmina Ließmann Tested-by: Jasmina Ließmann <code@frauliessmann.de> Reviewed-by: Timo Hund <timo.hund@yahoo.com> Tested-by: Timo Hund <timo.hund@yahoo.com> Reviewed-by: Nicole Cordes <typo3@cordes.co> Tested-by: Nicole Cordes <typo3@cordes.co>

History

#1 Updated by Christer V over 2 years ago

  • Subject changed from Opening links in pop-upwindows no longer works to Opening links in pop-up windows no longer works

#2 Updated by Georg Ringer over 2 years ago

  • Sprint Focus set to Stabilization Sprint

#3 Updated by Christer V over 2 years ago

  • Target version set to 8 LTS

#4 Updated by Gerrit Code Review over 2 years ago

  • Status changed from New to Under Review

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/51830

#5 Updated by Christer V over 2 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#6 Updated by Riccardo De Contardi almost 2 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF