Project

General

Profile

Actions

Bug #79926

closed

InvalidTemplateResourceException never thrown

Added by Markus Gerdes about 7 years ago. Updated almost 6 years ago.

Status:
Closed
Priority:
Must have
Assignee:
-
Category:
Fluid
Target version:
Start date:
2017-02-20
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
8
PHP Version:
7.0
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

typo3_src/vendor/typo3fluid/fluid/src/View/TemplatePaths.php Line 588 seems not to reachable.

Reproduce:
1. set templateRootPaths.0 to another location with a typo in the path name
2. open the page where the template should be rendered.

Default template is used instead of displaying an error message

In my case I had tx_hairu and configured fileadmin/Resources/Private/hairu/Templates/ via constants
The path to the templates was fileadmin/Resources/Private/hairu/Template/ (missing s)

The following line seems to always add the default path to the configured path
$paths[$name] = array_merge($defaultPaths, (array)$configuredPaths[$name]);

this line in 8.5.1
$paths[$name] = (array)$configuredPaths[$name] + $defaultPaths;

So in the end the default template was used to render the LoginForm.

I would think that, this is not the desired behaviour.


Related issues 1 (0 open1 closed)

Is duplicate of TYPO3 Core - Bug #81099: Extension cannot override default (fallback) templateRootPaths/partialRootPaths/partialRootPathsResolved2017-05-01

Actions
Actions #1

Updated by Benni Mack almost 7 years ago

  • Target version changed from 8 LTS to next-patchlevel
Actions #2

Updated by Claus Due almost 6 years ago

  • Is duplicate of Bug #81099: Extension cannot override default (fallback) templateRootPaths/partialRootPaths/partialRootPaths added
Actions #3

Updated by Claus Due almost 6 years ago

  • Status changed from New to Closed

Closing as duplicate of issue #81099 which has a further description of the problem at hand.

Actions

Also available in: Atom PDF