Feature #79928

PageTS config from file not localizable

Added by Kevin Ditscheid over 3 years ago. Updated 7 months ago.

Status:
Rejected
Priority:
Could have
Assignee:
-
Category:
FormEngine aka TCEforms
Target version:
-
Start date:
2017-02-20
Due date:
% Done:

0%

PHP Version:
7.1
Tags:
Complexity:
Sprint Focus:

Description

In the function \TYPO3\CMS\Core\Utility\ExtensionManagementUtility::registerPageTSConfigFile() one can not enter a language string like LLL:EXT:my_ext/Resources/Private/Language/locallang_db.xlf:pages.pageTSconfig.my_ext_be_layouts because the title parameter will be concatenated with the extension key in braces, thus breaking the LLL replacement logic. If one does add the LLL string, the replacement will be an empty string.
Could we remove the extension key part or at least detect, if the title is a LLL string? It would be nice if we could use the LLL replacement logic here, too.


Related issues

Related to TYPO3 Core - Feature #77540: ExtensionManagementUtility::addStaticFile language handling for $title Rejected 2016-08-18

History

#1 Updated by Georg Ringer over 3 years ago

  • Tracker changed from Bug to Feature

#2 Updated by Kevin Ditscheid over 3 years ago

This also applies to the function \TYPO3\CMS\Core\Utility\ExtensionManagementUtility::addStaticFile() of the same reasons

#3 Updated by Sybille Peters 11 months ago

Still reproducible in 9.5.11.

Is this not a bug?

#4 Updated by Georg Ringer 8 months ago

  • Related to Feature #77540: ExtensionManagementUtility::addStaticFile language handling for $title added

#5 Updated by Gerrit Code Review 8 months ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/63693

#6 Updated by Gerrit Code Review 8 months ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/63693

#7 Updated by Georg Ringer 7 months ago

  • Status changed from Under Review to Rejected

I am closing this issue because it would lead to an inconsistent behaviour in the backend. Having the extension key added to the label is very nice as it improves the search a lot.

If you need it translated - which I fully understand as well - please modify the TCA directly which is absolutly valid too by adding it to $GLOBALS['TCA']['pages']['columns']['tsconfig_includes']['config']['items'] directly.

Also available in: Atom PDF