Bug #80316

Misleading deprecation message for GeneralUtility::requireOnce/requireFile

Added by Mathias Brodala over 2 years ago. Updated about 1 year ago.

Status:
Closed
Priority:
Must have
Category:
-
Target version:
Start date:
2017-03-17
Due date:
% Done:

100%

TYPO3 Version:
8
PHP Version:
Tags:
Complexity:
no-brainer
Is Regression:
No
Sprint Focus:

Description

The methods GeneralUtility::requireOnce() and GeneralUtility::requireFile currenty log a message like the following upon usage:

TYPO3\CMS\Core\Utility\GeneralUtility::requireOnce() - since TYPO3 CMS 8, this file will be removed in TYPO3 CMS 9

Since GeneralUtility.php is unlikely to be removed that soon, this should be fixed. ;-)

Associated revisions

Revision 3497ff3b (diff)
Added by Mathias Brodala over 2 years ago

[BUGFIX] Fix deprecation message of two GeneralUtility methods

We're only deprecating these two methods, not the whole file.

Resolves: #80316
Releases: master
Change-Id: Ia1727c0996f53caa35d4755d2d5caa04bc48de46
Reviewed-on: https://review.typo3.org/52071
Reviewed-by: Wouter Wolters <>
Tested-by: Wouter Wolters <>
Tested-by: TYPO3com <>
Reviewed-by: Tymoteusz Motylewski <>
Tested-by: Tymoteusz Motylewski <>

History

#1 Updated by Gerrit Code Review over 2 years ago

  • Status changed from In Progress to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/52071

#2 Updated by Mathias Brodala over 2 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 50 to 100

#3 Updated by Benni Mack about 1 year ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF